Playbeat 3.1.7 Crashing in Reason 12 new update

Hi again,

A Heads up

With the new update from Reason 12.2.8 some weird anomalies have appeared related to Reason itself. Their Umpf club drums is more blurry once one zooms below or above 100% in this update, not the best Hi-res they claim. Their Drum Sequencer just crashed with this update and now Playbeat is crashing, too. What a mess. For folks on Reason 12, do not update.

Is this an update or a Beta version? Which is your OS?

Hi there,
Reason 12.2.8 is an official release not beta. It might as well be :smiley:
My OS : Intel(R) Core™ i7-3770 CPU @ 3.40GHz 3.40 GHz - Win 10 x64

I tested a few things and my CCleaner running its Performance Optimizer in the background may have caused anomalies. Removed it and tried again with Playbeat 3.1.7 but unfortunately Playbeat in Reason 12.2.8 crashed again, ouch.

I had playbeat running a usual loop inside the device and changing presets etc and I only had a Reason redrum present at the time and they were not linked in any way nor was redrum playing. After around 6 to 8 mins in it seems to fry up and crash :frowning:
Playbeat, was working fine with the previous Reason update.

I have an open support ticket with Reason at the moment but they did mention that they are on on summer holidays, still! Hehe, no worries I guess :grinning:

Reason 12 was initially released as a beta for the public to buy!!! They started with a new script for version 12 and there is still a number of bugs to work out. I understand it may take time as they have to implement VST3 and M1 also.

And, lastly, Playbeat 3 concept and design is excellent and although midi learn doesn’t seem to work in Reason I am very happy with workarounds and the cc/key mapping, thank you :wink:


I ran Playbeat 3.1.7 with Reason’s 12.2.8 for around 40 minutes last night and finally there were no problems. Ran smoothly and felt great.
Now, although I had removed Playbeat Lite and a Playbeat 3 trial from Reason 12.2.7 there was still some trace on my PC for whatever reason, so, after removing these, everything is running as it should now in Reason 12.2.8
I’ve just updated my Windows 10 yesterday, too - Maybe this helped, too

Anyhow, I hope this holds out, obviously. Again, Playbeat 3 is a great device and I am so so glad it is running properly. I saw this issue as ‘my own/Reason 12’ problem and not a Audio Modern problem as such.
At the moment my issue is Solved
Thank you very much for your help :slightly_smiling_face:

1 Like

Just popping in to give a heads up for Audio Modern to check out Reason 12.2.9

On my Win10 i7 3770 3.4Ghz I was using a 512 buffer size and getting glitches in sound and visual on any song in general with any device. Since this update I can now go to the lowest setting of 64 buffer size, sample rate 48,000 and it is VERY smooth.

So, what have they done to make this happen? A rewrite of how Reason handles multicore audio, that’s how.
With this update they have just put themselves back in the limelight, finally, getting to grips with their new script, it is very good. I look forward to any new project from now on especially with Playbeat.
New preference options for setting the max number of threads Reason’s allowed to use
View More Info about Max Audio Threading here:

1 Like