Loopmix 1.10 crashes Studio One when playing different VSTi

Opened a very small project (4 Tracks - one VST (LoopMix) plus 3 audio tracks with samples. All four tracks have event data - Loopmix has a two bar MIDI pattern in its track . When I added a 5th track (instrument track with Arturia Mini V3 via Komplete Kontrol) select a patch from my S61MKII keyboard and start playing - Studio One instantly starts a hard freeze for a few seconds and then disappears completely.

This is completely reproducible as I did the exact same steps again with the same project and encountered the same outcome. Diagnostic reports were created by Studio One and indicates that LoopMix is most likely the culprit.

The most bizarre UI item I noticed - just BEFORE the crash - was that Loopmix (on track 1) seemed to continue to accept keystrokes from the S61 (and was even making sounds) - all while Track 5 (the Mini V) was in focus, record armed and producing sound. I have never seen this before with ANY VST within Studio One.

Usually when a specific VST instrument track is selected (in a project with say a half dozen others) - it ALWAYS takes exclusive focus, is armed for record/monitoring and when I play the S61 - it should be the only sound source I hear while all others should either be silent OR playback the midi entered on that specific track when Record is engaged.

This crash today occurs while simply adding a new track/VST, sampling a few notes from the new VST while I can see the keys in the Loopmix keyboard being pressed as well.

Have never seen a VST hog the keyboard like this.

The crash reports have been sent to Presonus and LoopMix is now gone from the project. Adding Mini V back into this project works fine now.

Whatever LoopMix is doing as a VST - needs to be looked at.



Hello Sonic,

Thanks for the information and sorry to hear that, there are many reasons that could cause an app to crash,

  1. is it possible that any MIDI learn/CC is triggering Loopmix?
  2. Have you tried adjusting your buffer settings?
  3. Does the crash occur with a certain preset or it is totally random?
  4. Does that happen in another DAW?
  5. Does it happen in Standalone mode?
  6. Could we please have the crash-log that is generated so we can inspect and see what is causing this behavior? You can send it to us using the contact form here: https://audiomodern.zendesk.com/hc/en-us



Looks like I may have found the issue.

In Studio One - the Native Instruments NKS integration piece sets up several different “external devices” which LoopMix sees as “midi inputs”.

When I really dig into this project and started looking into the LoopMix settings - I noticed that Loopmix (for whatever reason) does NOT activate the default external device for my S61 - that controls not input.

It was actually “activating” several other devices (Under the Settings cog wheel->MIDI Inputs) one of which is actually permitting a key press that is intended for Track 5 - is actually happening in LoopMix at the same time.

As soon as I removed all other active MIDI inputs - and ensured that Loopmix was using the default input as defined by Studio One - all was well.

Also just heard back from Presonus and they confirmed that this crash was caused by the VST3 version of Loopmix.

Not sure what’s next - but it appears that when the VST3 version of Loopmix is added to a project - it is not reconciling the external devices (and default ) MIDI input within Studio One. Probably some work to do there.



Thanks for the information,

Are you able to choose as input only the ones you actually need for Loopmix, for example the MIDI Keyboard? and deactivate the rest of these “external devices” ?

Yes - but that feels like a manual task each time. No problem for the short term.

That said - the UI is a bit odd in that it is difficult to tell when a MIDI device is on vs Off? Is ON when the device selection text is white? Or the other way around?


I see, we may need to test with a same setup to understand that type of issue, Native Instruments NKS integration should not affect Loopmix in any way.

A midi device is selected when the button is highlighted in red.

Let me know if that’s working for you

Thanks for the update. And yes I see the red highlight now - but for us color blind old guys - this could be better :slight_smile:

More interesting is this. When I fire up LoopMix (Standalone) - it lists 5 items on my system as being MIDI (capable) inputs:


You can see how LoopMix “automatically” favors Host Midi (1) and in my case - (3) Komplete Kontrol EXT -1 which is NEVER supposed to be used unless the following is true:

Komplete Kontrol - EXT-1 is only needed, when an EXTernal MIDI device is attached to the Kontrol-S61 (eg: a hardware synthesizer) In this case it needs to be configured as a MIDI-Out device. If no external hardware is attached, the EXT driver should not be used"

Now - in standalone mode - even with (3) selected - LoopMix will work just fine - presumably because (1) is handling the keyboard input from my S61.

However - if I start a brand new Studio One project where (2) Komplete Kontrol - 1 IS my default AND only MIDI input that should be considered - and then add the Loopmix VST3 to a track and open Settings - the MIDI inputs are set to the same as Standalone mode.

Matter of fact - Studio One does not even list a " Komplete Kontrol EXT -1 " device anywhere - to be used as a MIDI input - not in the System External Devices area and certainly not in my standard song template.

But as I found out in that mini project that started all this - when I went into Loopmix after hearing (and seeing) it’s keyboard keys going up and down (and triggering loop segments while I was attempting to play a totally different VST in the project (Mini V in this case) - I can tell you that LoopMix had the (3) Komplete Kontrol EXT -1 MIDI input active and that what was causing this issue.

As soon as I killed that and enabled (2) in the LoopMix MIDI Inputs area - Loopmix behaved like any other VST instrument would. If I select it’s track in Studio One - I can trigger Loopmix segments via keyboard, record MIDI data etc. When I highlight a different track in Studio One - Loopmix stays silent while I am playing another instrument and plays its track MIDI (if applicable) as requested when the Studio One transport is engaged.

So my questions are:

  1. Does selecting a specific MIDI input (and disabling others) in Standalone mode - represent “setting the default MIDI inputs” for the plugin system wide (including VST3 plugin mode) or does Loopmix need to be adjusted everytime I add it as a VST3 in a session?

  2. Why would LoopMix pick this bizarre MIDI input in the first place - if it’s not even listed in Studio One as an actual MIDI device that could be used?

  3. Finally - how does the Keyboard and Playback modes button effect all of this? Per the manual:

Play mode: Loopmix plays in accordance with the playback of your DAW (normal transport).
Keyboard mode: Triggers the different tracks using your MIDI keyboard or MIDI notes

I am assuming Play Mode is where I want to be AFTER I record my midi for LoopMix playback?



Thanks for the detailed feedback,
So far we couldn’t create the exact same setup to replicate the problem but we’re on it.

  1. Usually the first MIDI port should be selected by default, maybe a ‘save settings as default’ would help here?

  2. Loopmix is designed to detect all available MIDI sources from your Audio/Midi Interface.

  3. Play/Keyboard modes are two different performance modes, one triggers the sequencer as soon as your DAW timeline starts (no midi required) with default triggering All sequencers , keyboard mode will enable the sequencers only upon triggering them via MIDI.

What exactly does this mean (Save Settings as Default)? Where does one click to save settings as default in Loopmix?

I think you misunderstanding my observation/question. I totally understand that LoopMix is detecting ALL available MIDI sources - but I am asking why Loopmix is choosing to make very specific ports (out of my available choices) it’s default - when one of the ports it is favoring - will not work correctly?

Appreciate your comments on these items.


I meant that the first MIDI port will always be selected by default, unrelated to which setup was used in Standalone mode. Maybe here we can introduce the option to save custom settings as default and use that setup each time Loopmix opens. We can definitely look into this as we’re currently working for our upcoming update.

I can’t have an answer for the second question until we replicate the setup with these controllers in Studio One. This can be caused by a number of reasons, how the setup is connected, I/O interface or DAW settings.

So this project now get even more bizarre…

Here is the actual Studio One timeline - which I have moved the cursor out to bar 31 (1) - where there is nothing recorded and nothing should be playing.

When I hit Spacebar in Studio One - the transport fires up and the playhead starts to move - but Loopmix suddenly decides to (2) engage C2 - and starts playing this loop sequence for no apparent reason.

I am not pressing anything but Spacebar and definitely NO keys on my S61 - so what is going on here. This thing simply wants to play it’s loaded loopset ALL the time. How do I get this to stop? And this is with NO Midi inputs selected.

I must really be missing something here as this plugin seems like it will be completely pointless to my compositions until it behaves like every other VST - fires (Playback) when I need it to (usually triggered by MIDI data that I place on it’s track) and not while anything else is being demoed or written on other tracks.

It’s like this thing has mind of its own? What am I missing?


In Play mode the sequencer (C2 in this case) is triggered by default, you need to toggle to keyboard mode and trigger the sequencers via MIDI.

Just tried that:

With the cursor into the second bar here - this LoopMix midi (2) should be playing - but I hear nothing?

What else is not turned on here now?


Which notes are being triggered by your MIDI (2) ? Do they correspond to Loopmix keys?

Yes - this was working last week.

All the midi you see there should be firing the different portions of the loops loaded into LoopMix:



Is it possible that you have changed the octaves via the settings tab in Loopmix? (see screenshot)


Nope - all is good there?

I am wondering - could it be one of the MIDI inputs is not on - like Host MIDI?

That one is set to off right now. Will turn it on and try again.

EDIT: That was it! MIDI playback is back to normal.

So I am sensing that in order to get this to behave as a “normal” instrument - I need to stay in Keyboard mode, write MIDI data (to trigger loop segments as needed) and ensure Host MIDI is always on? Good?




The Host MIDI should be ON, yes. This will pass MIDI data from your DAW to Loopmix. Could you please make sure that one is enabled?

Perfect - thanks!

Will keep experimenting here with LM. It’s coming around :slight_smile:


1 Like