Riffer goes out of sync when changing presets

Just came up in my livestream: It seems that Riffer jumps immediately to the start of the loop when changing the presets. In consequence Riffer is out of sync with the rest of the music piece. Maybe it is not intended by the developers to change the preset while playing a piece? Or maybe I am using Riffer the wrong way? :thinking:

Hello kjlietz,

This shouldn’t happen. Are you changing presets for the bottom quick-load slots or through the preset manager (pencil icon) ?
Also, which is your DAW?

thanks for the quick response. I use Reaper, but I can try with other DAWs just for comparison if needed. I programmed to trigger the quick presets via my drum pads on my keyboard.
In my livestream I had different sequences for my bass line and wanted to change between them on the fly. But when I changed at the wrong time my bass line and my chord progression got decoupled as the change of the sequence made Riffer start at the beginning of the sequence while the rest of my other Midi-tracks played on. I share with you the relevant part of my livestream. Since it is in German, just watch the presets and listen how things went out of sync. At that time I tried to understand what was going on. So I did it on purpose. Livestream: Bombast Blues - ein Interim Projekt - YouTube

Thanks for the information, please try to also click to select an quick-load slot too and see if you have the same result while the DAW is playing.

Just clicking the quick load slots has the same result :slightly_frowning_face:

I also built the same project in Cakewalk with the same result. So it is not on Reaper.

Okay, i can see that the presets are using different time signature, maybe this is causing this behavior. We will take a closer look and update you.