Playbeat: User Presets can kill audio (at the iOS/hardware level)

This is really frustrating. I’m on iPad Mini, latest Playbeat, iOS 15.8 (highest supported by my hardware).

I have my own presets, which use my samples, loaded via the ‘add folder’ feature in settings → samples.

If I start Playbeat, it always plays for a bar or two, then audio stops. Though, rarely, sometimes it massively reduces in volume. This seems to happen at the end of the bar.

Then I will find that OTHER APPS, like youtube, are not putting out audio any more.

I can usually recover from this situation by ejecting the running playbeat app and starting again. But typically, this problem will happen over and over again, leading to a frustrating 30 minutes of not being able to do anything at all with playbeat.

I have tried to diagnose what’s going on, but the only thing I can pin it on is the User presets I created. Factory presets and downloaded packs from your website don’t create the same problem.

Any help appreciated.

Hello bibenu,
Thanks for reaching out. This is really strange. Our Factory packs are no different from the user presets and are created exactly the same way.

What types of audio files are you using for your user presets?
Is this happening in standalone mode or when using the app as an AUv3?
Can you please share a pack with us which produces this issue so we can investigate?

My sample collection comes from varied sources could be mono or stereo, 48.0 or 44.1, 16 or 24 bit. I didn’t check the particular ones in this pack. They are all wavs.

This is standalone mode.

I’m attaching the pbpack file. No I’m not … apparently the forum doesn’t like the file extension.

Here’s a dropbox link to the file: Dropbox - Fbit1.pbpack - Simplify your life

EDIT: The particular preset I want to get working is “andy9_mega”.

Thanks for sharing,

This particular preset does not seem to contain any sounds. Andy8 does not contain any sounds as well.
Are your sounds stored locally? Can you please try to re-export the pack?

This is a new export of just the problem preset. Dropbox - mega9-only.pbpack - Simplify your life

EDIT: You might have to explain to me how to get the sounds into the pack, they appear, from the size of the file, not to be included.

Locally on my iPad, the sounds are loaded into the 8 tracks of the preset. Then I drag the preset into the pack, and export the pack. What else do I need to do, did I miss a step ?

Thanks, this pack also appears to be without sounds.
Although the process seems to be correct.

Where are the samples located exactly on your iPad?

They’re in a folder I created in the root of the ipad, but several levels down, I have a whole folder structure that I use across different apps (and different devices). The exact path for one of the samples is ‘On My iPad’/Samples_ipad/Plusdrive_ipad/A_PERC/P_SKIN/DjembeS5_cy_perc 2.

The folder is accessed via the ‘add folder’ feature in settings → samples. I added the path ‘On My iPad’/Samples_ipad/Plusdrive_ipad to get access to my folder structure.

Thanks for the information,

If you are able to load the sounds to the preset and hear them, but not being able export it within a pack is strange, I can only assume that there must be a security setting preventing access to this folder, which could explain the first issue.

Can you please check if there are nay folder restrictions, or try with samples located in another folder?

Sorry, I don’t know about file level security on iPad, I certainly didn’t deliberately set anything. Can you tell me where to look ? Point me at a video or webpage I don’t expect you to explain.

I will try a test folder with a shorter path.

I have to say, I wonder if this fail to export (possibly the audio bug too) is a quirk of the ‘add folder’ feature, combined perhaps with some iOS versions ?

Here’s a short guide about Privacy & Security settings:

So far we haven’t received any similar reports on this functionality, so we’d like to learn more about this. Can you please check if sounds from another file location are working properly?

Also, would you be able to share the audio file used in order to check the file type?

Here’s an export using a shorter path to the wav file. Dropbox - andy9-short-only.pbpack - Simplify your life

The Local path was ‘On My iPad’/Sample-playbeat/clave_A11_samplar.wav … it’s used in track 8 of the preset.

EDIT: Playbeat definitely has been allowed access to ‘Files and Folders’

EDIT 2: The new file on the short path (also has been missed from the export I think) is shared here: Dropbox - clave_A11_samplar.wav - Simplify your life

Let me know what else you’d like me to try or to send to you. I think I responded to all your requests.

Noting versions:
Playbeat: 3.2.5 (running standalone)
iOS: 15.8 (latest for my hardware)


The pack still hosts no sounds. Did this happened after a recent Playbeat update or OS change? Or during first installation?
Have you tried to delete the app and do a ‘fresh’ re-installation?

I’m new to playbeat, so everything I’ve done is on 3.2.5. Regarding iOS, when I first installed playbeat, I encountered the problem on iOS 15.4.something. I wondered if it was an iOS bug since fixed, so I upgraded to 15.8, but found I still had the same problem.

I can try an uninstall/re-install of playbeat, and see how it affects the sample export problem at least (the ‘kill audio’ problem is intermittent, so may not get an answer straight away)

Export after new install. Factory pattern, half samples are mine, added via the ‘add folder’ facility as before.

Thanks for sending this over,

Unfortunately this pack still does not host any sounds. Something is preventing the sounds to be collected during pack exporting which is highly unusual as Playbeat expansions should work across any device on Desktop or iOS. I assume that this might be causing the first issue mentioned above which again is a strange behavior.

We will need to try to replicate this with an iPad device running 15.8 to see of any missing updates could be causing this problem or an incompatibility should be fixed on our side.

I would recommend that you ask for a refund through the App Store until we have some more news about this case. Thanks for your patience.

Hmm … you’d anticipate this taking a long time to solve then ? Or even difficult/impossible to replicate ?

BTW, I do appreciate the attention you’re giving to this issue, thank you.

We were able to test on 15.8 but could not replicate the problem. No issues when exporting a pack & sounds playback. May I ask which is your device model/make?

EDIT: Appreciate you guys working this close to Xmas :slight_smile:

Thanks, we will try to replicate this with a Mini 4.

As we haven’t received any similar complaint, at this point I can only assume there must be some incompatibility between the latest versions of Playbeat and the combination of iOS 15 + the Mini 4.

Do you perhaps have the option to test this with another iOS version and/or device?