Playbeat 3.1.5 Samples not showing up in Sample and Presets manager

After installing version 3.1.5 I can’t hear any patterns. I also don’t see a way to add samples, as there is no Samples category in the manager.

I am using Playbeat in Logic Pro 10.7.4 in an iMac running system 12.3

How can I fix this so I can start using it.

Hello judymunsen, I hope you’re doing well.

Since version 3.1.5 Playbeat comes with an additional bonus MIDI FX instance which allows Logic Pro users to use Playbeat as a MIDI FX too, normally this should be only available when trying to load it via the MIDI fx slot in Logic and not as an instrument.

I assume Logic’s cache needs to be refreshed.

You can try and restart your computer and if that doesn’t work you can do the below:

  1. In the Finder, choose Go > Go to Folder from the menu.
  2. Type ~/Library/Caches in the “Go to the folder” field.
  3. Press the Go button
  4. Remove the “com.apple.audiounits.cache” file.
  5. Remove the ~/Library/Caches/AudioUnitCache folder

The next time you start Logic, the installed Audio Unit plug-ins will be rescanned and Logic should then startup normally.

Let me know if everything works,
Max

Hi Max,

Thank you for your detailed instructions. Unfortunately it didn’t work. I removed the Cache folder and the .cache file, restarted and opened Logic. It took awhile to rebuild the cache, but once it did, there were still no Samples available in the preset window.

I am using Playbeat from the Instrument slot on the channel strip. I also tried to see what would happen if I loaded Playbeat from one of the MIDI slots (the MIDI FX slot and the AU MIDI controlled fx from the bottom of the Instrument slot). I have other Audiomodern midi fx that show up in both of those places, but no Playbeat option at all.

Anything else to try?

Thanks,
Judy

Thanks for the information,
I will have to transfer this to the rest of the dev-team to check what might be causing this.
Meanwhile, i have sent you a PM with the previous version for you to install.

Thank you for your patience,
Max

Hey @Audiomodern — I have the same problem, after installing the newest versions there are no samples in the logic plugin, nothing plays and the mixer can’t be chosen. can you also send me the previous version via mail please? or any updates on how to fix it?

Thanks for the information
You simply need to remove/trash the previous Playbeat file installation from the location below:

The AU plugin is at location:
/Library/Audio/Plug-Ins/Components

then re-install the newest version 3.1.5
Download: Dropbox - Audiomodern_Playbeat_Version_3.1.5.zip - Simplify your life

Let me know if everything is working as expected.
Max