Playbeat 3 - forcing Pattern Retrigger?

Hi there, I’ve got just some headache during my work in Cubase.
Midi Sync to Host usually works fine in Cubase. Problem appears, when I start at a later position in my Cubase 12 project - the Playbeat pattern starts not at the beginning anymore, so the pattern sync is gone.
Is there a hidden setting somewhere in the Playbeat plugin, to force retrigger of the patterns?

I had some more testing. My latest investigation is: happens here in a project with different tempo settings. Sync is tight with tempo 120 Iinitial), patterns starts “somewhere” and sync is lost in the section following at 160 bpm. Later in the same project I started a section with 140 bpm, and the sync works fine again. Maybe an issue with specific bpm settings?

Hi Syngularity12,
As Playbeat is designed to be in Sunc with your DAW have you tried to start the playback at the beginning of a bar and not from a random position? Do you have the same issue then?

Thank you - yes, I have always started playback

  1. at the exact beginning of the bar, example “33.1.1.0”
  2. there is no change of bpm during that section, nor right before or thereafter.

Can you try it also with Cubase there?
Playbeat 3 will get out of sync with various bpm settings (Host). After testing some more, I can not fix that issue to certain bpm settings. Kind of randomly, also depends on the chosen Playbeat presets.

I guess, Problem is the changing position in the Playbeat pattern, not the sync itself…

This is strange, can you make sure the ‘Sync’ button is on?
sync-on-btn

Yes, “sync” button is red, and bpm setting of Playbeat and Cubase are the same.

Playbeat pattern starts at the 4th step, when starting playback in Cubase at the beginning of a bar.

Thanks for the information,
Is the same thing happening if you start the playback from Bar 1 ?

I’ve just created an empty Cubase 12 Pro Project.
From Playbeat using the preset “On the Scrambles”, which has 32 steps. Sync activated.

  1. Loading Patterning, sync from bar 1 in Cubase, no project loop set.
  2. Playing a factory preset of Playbeat along with the Cubase Metro Click.
  3. Playbeat pattern starts perfectly with the 1st step -at 120, 130, 140, 150, 160 bpm

Now I start playback from bar 8 in Cubase

  1. Playbeat starts with step 16 at 120, 130, 140, 150, 160 bpm

Now I start playback from bar 9 in Cubase
3. Playbeat pattern starts perfectly with the 1st step -at 120, 130, 140, 150, 160 bpm

Now I start playback from bar 10 - in Cubase - Playbeat starts with step 16

So the behaviour is in a Cubase Project without tempo changes - Playbeat starts with step 1 from uneven bars, and with step 16 from even bars. This behaviour is identical with patterns running from the Maschine software.

Now I’m setting sections with different bpm in Cubase, still the same Playbeat preset

  1. 120 bpm at bar 1
  2. 140 bpm at bar 6
  3. When starting playback of the playbeat pattern on bar 9, it displays correctly 140 bpm. Sync activated.
  4. Playbeat starts with step 12

I did some more tests with the Cubase tempo track - Playbeats always stays in sync and displays the correct bpm, but starts at various steps in the pattern.
The Maschine software pattern on the other hand starts correctly at the beginning, or in the middle of a pattern.

As sound designer my work depends a bit on sections with various bpm settings in a big modular Cubase project, as in any more complex song project.

I could live when a Playback pattern starts in the middle - I would just nudge the whole arrangement, until it does match with the sync playback from start.
But I cannot use currently Playbeat is those projects with variable sections, when a 32 patterns starts sometimes correctly, then at step 4, and sometimes even at step 20.

I remember that behaviour from the iOS app Ochtachron, which could get fixed.

So I guess, I was right with my initial feature request - Retrigger Pattern start.

Can you please make this possible?

Thanks so much for the detailed explanation. We are going to replicate the problem and correct with our upcoming update.

Thank you for your patience,
Max