Playbeat 3 and midi out in Studio One 5.4

Hello all, hope your holiday has been fantastic. I am trying to use Playbeat 3.0.6 as a controller for Sugar Bytes DrumComputer 1.2.4 in the most current version/build of Studio One, but I have yet to succeed. I have done this successfully in Live by going to Settings in Playbeat 3, setting all tracks to Omni and then doing the midi routing in the usual way for Live 11. So you would think that by doing the equivalent in Studio One that things would go off without a hitch. However, it does not. Even when I set all 8 tracks in Sugar Bytes at c1 and ascending, I don’t get anything more than an occasional drum hit. To confirm that this isn’t a Drumcomputer issue I loaded up Atlas 2.1.1 and also Presonus Impact as included in S1 5.4, but again I cannot achieve the desired result. So I’m down to 2 possibilities it seems, either there is something special that needs to happen with the routing, or Playbeat 3’s routing in Studio One does not work as expected.

Has anyone else had luck doing this kind of thing in S1? Thanks!

Hello gloriousballoons, I hope you’re doing well and safe.

Have you tried via internal MIDI Routing options as shown here? PLAYBEAT 3.0 by Audiomodern | Settings - YouTube

Let me know,
Max

Hi Max, thank you so much for your reply. I toggled the fixed note output per the video, and here’s where it gets really strange – track one works, but the others do not. And when I say works, I mean that it’s good for any singular note that I select., c1, d#1, you name it. To once again ensure that it’s not drumcomputer alone I loaded Presonus Impact, the house one-shot drum instrument. Sure enough, it also works fine on any drum hit assignment for track one. But 2-8, I can’t get any response out of.

Have you tried to set the Plugin MIDI out to ‘All’ as shown in the picture below?
PMoutALL

I went back in to confirm and yes that option is toggled. Attached is a screencap so you can see how I look over here. Thanks for all of the help!

Thanks for the screenshot,

I found out that changing the channel Input selector in SO (CH1/CH2/CH3 Etc…) will enable the rest of the channels playback (see screenshot below)

So i assume SO works a bit different than Live when it comes to MIDI input(s) and it appears to handle them individually.

It is related to SO and not Playbeat, so at this point i will reach out to their support team asking how to receive multiple MIDI inputs in one track and let you know once i have the answer :slight_smile:

Ahh, how about that! Yeah cool, let me know what you learn. If nothing else I’m wondering if loading PB and DC in Unify would be a good workaround since you can do channel splitting in the plugin.

Max et al –

Is there a way to save a preset in Playbeat 3 where the routing is always fixed? If not I can just config it in each subsequent project but perhaps that can be added in a future iteration??

Beyond that, I’m assuming that no news is bad news, from Presonus. That’s a shame if so, considering how much I want Playbeat 3 into Drumcomputer to be my default starting point. But what can you do, I’m sure that now that you’ve put light on it that they at least see that it’s a routing issue that needs addressed. But to any S1 users that see this, do know that you can connect Playbeat 3 to 8 different samplers, synths, etc and if anyone has any questions as to how to do that feel free to reach out to me.

Thanks and happy new year!!

Hello gloriousballoons, happy new year!

Can you please make sure you have the latest version 3.0.6 installed?
The routing should always be saved along with the plugin state.

Unfortunately no news from Presonus yet, if you could also reach out to their support with a ticket i am sure it would help.

Hello,

Yeah I’m on 3.0.6 but when I re-open a project, each track is still toggled as fixed, but the note always reverts to C3. Also I will reach out to Presonus and let you know if I hear anything. Thanks!

Edit: Studio One 5.4 doesn’t hold the fixed key assignments, but Live 11 does

Hey!!! So far as I can tell, you’ve completely fixed this issue.

THANK YOU. From the bottom of my hearty, thanks.

1 Like