MIDI Learn on Playbeat does not toggle properly

I am using PLaybeat 3.1.1 and Ableton Live 11.1 - When I made a toggle CC to Mute a Channel, I have to press the button twice to get it to turn on, and then twice to get it to turn off. I tested on 2 different hardware devices - Nano Keys and Launchpad X. When I use exact same keys to toggle a button inside Ableton, it works as expected - first press turns off, second press turns back on. I use Learn function to set the CC. Anyone else confirm this? Am I doing something wrong… it seems so basic.

Hello David, I hope you’re doing well and safe.

Thanks for reaching out. I was not able to replicate this, but i have transferred the info to the rest of the team in case it is a device-specific problem which we can correct with a quick update.

Thanks for your patience.

Hi Max,
Thanks for the prompt response. I will make a short video to illustrate what I am experiencing. I hope that will assist you and the team in determining if this behavior I am seeing is specific to me, or is something in the software which can be adjusted.

Here is the video I made to try to illustrate the issue. I hope this helps.
issuewithplaybeatmidimapping - YouTubehttps://youtu.be/wDv8ptMNIr4

In the video you can clearly see at the end that a simple on/off toggle using a CC value of 0/127 does not simply enable/disable “Mute” on a channel in Playbeat. I have to press the physical controller key twice to toggle in each direction. Is this the bahavior you attempted to reproduce Max? I wanted to make sure you understand the behavior I am seeing.

Hello David,

Thanks so much for taking the time to shoot a video for us. While we can’t test with the same controller, this definitely seems like an issue on our side. We will try to correct with a quick update ASAP.

Thank you for your patience,

Max, Thanks for the reply. I am glad that the video was helpful, and it is reassuring to know I am not somehow doing something incorrectly. I anxiously await the software update to fix this!

Hello David,

Kindly check your PM.



I will check this version shortly. Thanks for the prompt action- I will let you know how it goes.


The version you sent does in fact fix the issue I was seeing with the MIDI toggle behavior on the Mute buttons. Thanks!

Glad to hear that David,