Chords doesn't change in RAND mode

Hello, please tell me what am I missing. here’s the video

Why Chords doesn’t change in the Robot sequence area? is this a bug or am I doing something wrong?
Thank you

Hello Igor and welcome to the Audiomodern forum!
You can generate random Grooves by selecting the “Random” preset. By selecting this preset, you will also be able to adjust the number of chords that will be generated for your sequence using the “Number of notes” slider on the main page.

Please let me know if you need any further help.

thank you for your reply @Miltos
yea, I got the thing with rhythm generation, but in my case, I don’t need to generate rhythm (otherwise I’d do what you suggested), instead, I want to randomly change chords, From A to C for example, while rhythmically pattern needs to be the same.
Is that possible?

Igor, in this case, I would try to do this:

  1. Create a rhythm in the sequencer and save it as a preset
  2. Select the chords I want to randomly change positions
  3. Have the infinity button active while the DAW is playing
    or hit the random button in the sequencer

Let me know if this works for you.

Thank you Miltos, it works this way. But this method looks more like a workaround.
isn’t it logical and easier if we don’t need to create a groove preset for this?

I feel like just switching to RAND should do this thing, otherwise this switch is useless, this is misleading.
Creating a new rhythm pattern each time I want it to function like this is quite cumbersome, I’ll end up with tons of patterns one pattern per song (minimum)

Also, another thing, is there any way to make Chord type

affect chords in the robot sequencer? I couldn’t find a way to do it.

To me it would be logical if I
01 select a chord in the sequence image

02 Hit trigger button here image

and as a result, the chord type in the Robot Sequencer changes randomly according to the Chord Type list.

So far it looks like Chord Type randomisation works only when I play live on MIDI keyboard

Hello Igor,

The “Random” option provided by the PROG/RAND button is connected with the keyboard diagram.
This allows you to generate progressions by selecting keys through the keyboard diagram, but the chords/notes in the patterns that will be generated by the robot sequencer will always be in random order.

In the current Chordjam version, in order to prevent your custom rhythmic pattern from being randomized, you need to save your rhythm as described by @Miltos above.
Please also note that you can select a chord to enter the Edit mode and randomize or adjust all parameters.

As we regularly update all of our software plugins, we will include the option to “lock” the currently playing rhythm, without being saved as a rhythmic preset and allow any selected parameters to be randomized by the infinity or randomization buttons.

Chordjam provides many options to affect the chord types of the robot sequencer.
Without having selected any of the chords in the robot sequencer, you can select another chord type using the Chord Type drop-down menu. This will apply to all chords in the robot sequencer.
You can also enable the Trigger button for the Chord type and click the “R” (random) button.

If you would like to adjust or randomize the chord type for a specific chord, you will need click the chord to enter the Edit mode. You can adjust the chord type using the drop-down menu, or enable the Trigger function and click the “R” (random) button to randomize it.

thank you for your clear answer Katerina

am I understanding and doing this right, If yes, why he chord type isn’t changing, if not, what I’m I missing :slight_smile: ? please check this screencast

Thank you for sharing this screenshot.

Although we can adjust the Chord Type using the drop-down menu, it seems that the random button does not correspond while a chord has been highlighted.
I have transferred this to our developers and will be fixed with a quick update. Thank you for your patience!

aah thank you for confirming, I was about to think I’m too dumb.
looking forward to the fix