Saving Playbeat iOS midi out settings

I am trying to use Playbeat to run XO. I can set it up but the settings do not appear to save correctly. In order to get them to work, I have to turn each midi Chanel of and on again and select each note to match the those in XO, which kind of defeats to object of saving in the first place.
Am I doing something wrong or is this a known bug. Any help appreciated.

Hello Shemloo,

Thanks for reaching out and sorry to hear that.
We couldn’t replicate this, Saving the MIDI output setting should definitely be saved along with the preset.
Can you make sure you have the latest 3.1.0 version installed?
(You can see the version by clicking the info icon on the top-right side of the UI)

Also, can you make sure the ‘plugin MIDI Output’ drop-down is set to ‘All’ ?

Hello there
Thank you for the response. I can now save midi settings which is great. However, I have another query.
If I use the new remix feature it seems to reset the midi settings to all play C, apart from occasionally also playing an additional key. Basically you end up with lots of triggered kicks!
This doesn’t seem to happen with any of the other remix features which keep the midi settings and continue to play them.
Not sure if this is a bug or I am doing something wrong. You help/advice would be most gratefully received. This happens in both stand alone and Auv3.

Just noticed that if I go into settings after pressing new remix button and turn fixed note off and on again, this resolves the issue.

Thanks for the information,
We can’t replicate this issue too. The MIDI outputs should be saved along with the preset and stay intact regardless of the randomization mode.

Can you please let me know your OS/iOS Version and DAW that you are testing? We’d like to run some further tests on this.

Hello there
I am running iOS 15 and Ableton Live 11

Thank you for looking into this


Hello there
Did you manage to replicate the issue I raised or is it down to my user error?

Hello there
I bought the windows version to see if it had the same issues and it does. You have probably figured it out too but the issue arises from each preset saving its own individual midi settings. Which means that whenever I select smart randomization and a FUSE, Factory etc. is selected, this effects the midi setup. Hence the issue noted.
I have gone through every preset and saved the same midi setting C1-G1 and now it works like a dream. This means I can now send to XO and still use the Smart feature.
If its any use, I am happy to share the presets with the midi settings applied. I haven’t altered them in any other way and it might make it easier for others when trying to figure this out.


Hello Shemloo,

At the moment indeed the MIDI output settings are saved along with the preset. Would it help if we provide a separate menu in this area which will allow you to save & load your own settings regardless of the preset or randomization mode that is chosen?

Hello there
I think that would be a great idea as it provides the flexibility to have specific midi set ups that can be used with other software and enables access to all presets without having to re define midi setup each time


We too think it is the best scenario at this point.
We will do our very best to include this to our upcoming update.


I am also having the issue in which the randomization function resets the fixed midi output. I emailed a support request, but I have not found a solution. Is there a way for this function to be saved? It very cumbersome. @Audiomodern

Hello noirc,
I assume that happens only when using the new ‘Smart’ mode? This is a small issue on our side which happens on certain OS versions and we will correct it with a quick update in the next couple of days.

1 Like