Playbeat 3 as a MIDI-FX in Logic Pro, to sequence drums

Hi there

I had some issues installing playbeat3 as midi fx in LogicX, but it’s installed now.
But i cannot get the playbeat3 to send midi to any drum plugin or synth on the track.
This is the whole reason to use this as a midi fx plugin, not an instrument.

Playbeat works fine as an instrument, but as a midi fx it wont send any midi.
I can use riffer in this way, and i would just use that, but it’s hard to use for drums because you cant double up notes in riffer.

Anyone using this method in there current Logic X setup, could you help me with how you got it working :slight_smile:


Here is a screenshot of the output settings.

Thanks for the scattershot,
What is your Logic version and OS version?

Thanks for the screenshots.
I assume that it is a problem related to M1 setup.
I have forwarded the problem to the rest of the dev team so we can correct with a quick update.

Thank you for your patience.

Hopefully there is a fix, because it seems like a great tool.
I should mention I tried running Logic is ‘rosetta mode’, but still. no luck.

Guessing this issue has not been resolved as I am on the updated version, but any word as to if you all plan to work on this? Really would like to use Playbeat to control a few other VST-i! :metal:t5:

Hi TvMcC,

Have you tried with the latest version 3.1.7?
you can grab the update here: Latest Software Updates | Audiomodern

Just stopping in to let people know the update does resolve this issue! Big ups

My experience:
I can get the plugin loaded as a midi Fx.
It will only trigger the first track (kick - c3), when using a full sequence.
When i try to change the fixed note output the plugin crashes.

I figured out a workaround for the crashing:
put a transposer plugin (at -24 st)
underneath the playbeat midi fx.

so yeah it’s working now. thanks

PS- the devs might want of take note of this bug

Uploading: Screen Shot 2022-08-30 at 9.31.31 pm.png…

Thanks for the information,
This definitely shouldn’t happen. Do you perhaps have a crash log you may share with us?

Same problem here. Midi plugin not sending midi. If I drag a midi file from Playbeat to the track,it plays back as expected but will not work correctly as a midi plugin. osx Mojave. Logic 10.5.1. Playbeat 3.1.5.
Please fix asap. Thank you.

Have you tried the latest version 3.1.7?

I only installed this the other day so that was quick. I shall do that now. Thank you.

I can confirm it now works as it should and that was officially the fastest service from a software company I have have ever received. 5 Stars to you.

1 Like

This is pretty cool. Now I can save Logic instruments with midi play back sequences as a Patch. Good work chaps.

How did you get it in Midi FX? I just cant get it since it was announced…

You will need to do an install of the ‘midi fx’ plugin, in the installer where you select vst/au/ etc. make sure you install the midi fx plugin.

1 Like

OMG, thank you sir! Finally i’ve got it! :black_heart:

No worries.

As i told the devs above, the midi fx plugin crashes when you try and change the note output. the solution is to insert a ‘transpose’ midi fx after it, at -24 semitones.