Bitwig - Playbeat 3 - Midi output apparently incorrect

Bitwig 3.3.10, Windows 10, Playbeat 3.1.1

The midi being sent is not the same as midi supposed to be sent.

Hello SpringGoose,
Thank you for reaching out. So far we are unable to replicate such an issue. Can you please tell me if you have the same result using another DAW or trying to ‘feed’ another Plugin?

The “midi monitor” VST app is between Playbeat and Battery, so it isn’t a problem of Battery.
I don’t have another DAW to test it. I only know about the problem in my Bitwig 3.3.10

You agree Playbeat apparently is sending out weird midi, on channels 2-8 and octave higher than supposed to? I mean i have set it up correctly?

Unfortunately not. We have tested on many DAWs and each time the note that is set on MIDI outputs section, is the same that is being fed into the DAW/MIDI Track.

Is it possible that you have made any special configuration within Bitwig, or your MIDI interface settings?

I haven’t made any special configuration in Bitwig. I don’t have a midi interface, and i don’t understand what midi interface has to do with it if its Playbeat which is generating the midi.

I can make the sequencer behave normally by starting afresh. As soon as i hit the smart random button the problem thereafter occurs. It’s possible to temporarily fix the problem by turning each Fixed Note Output off then back on again, but then hitting the smart random button again makes the problem occur again. If i leave the sequencer running with the problem occurring then sometimes after a while it start working normally again without fixing the problem.


Thanks for the information.

So the problem here is not that Playbeat falsely transmits an incorrect MIDI output. It is that MIDI outputs change when using the ‘SMART’ randomization notes.
Can you confirm that is the case? Do you have the same issue on ‘Remix’ or Full Random’ mode(s)?

I have sent you via PM our upcoming version which should fix this issue :v:

With a quick check 3.13 seems to be working normally and fix the problem!