Playbeat locking MIDI output

Is there a way to lock midi output permanently so setup won’t change while switching different patches with different output setups? And is it possible to lock empty sample slots while switching presets? It’s is kinda messy when I’m using Playbeat as MIDI output device and wanting to switch presets but both locked MIDI notes and
locked Sample slots changing and weirdly breaking output channel triggers.

Hi,
Have you tried to click on the “Lock MIDI outputs” button?
lckmidiotps001

Yes, sorry, I didn’t check this behavior in the latest version before creating this topic. There was something like bug in 3.1.9 so no matter what state lock button was, output MIDI notes were changing. So one part of the request turned out to be a bug.
But the other part needs some explanation.
I appreciate that you are listening users and very user oriented company :heart::pray:
I use Playbeat to trigger XO or Atlas samples because they have smart samples randomization.
I’m my use case I don’t need samples in Playbeat but if I load any preset, factory or from expansion, it loads and triggers sounds. Of course I can turn off Playbeat channel volume in DAW but I think it could be better to have MIDI out only when samples just not playing. Or a switch to turn sample triggering on or off permanently for all presets. Especially because samples starts playing with the wrong pitch when I’m locking output MIDI notes (not C3 or C4 - very low, starting from C1).
So for now every preset I want to load I need to click delete on every sample channel in browser.
Sorry for long text, hope it was useful.
Merci!

Understood,
So you are using Playbeat as a MIDI sequencer only, do you have the option to simply mute the channel that Playbeat is loaded?

Yes! And I did. I just think that turning off triggering could be more CPU etc efficient in big projects. Muting is an option here, agree!

1 Like