Loopmix crash in Reason and Ableton

I am attaching text from a thread over on the Reason forum. The behavior, as per the Reason devs, can be reproduced in Ableton, so the conclusion is that the issue likely resides within the VST’s code.

Initial report:
Ventura 13.0.1
Trial version here: Loopmix by Audiomodern | The Creative Loop Remixer

Add Audiomodern Loopmix VST3 to rack.
Open it, press space bar to play.
Close out of VST’s interface
Now delete the VST from the rack either by selecting it and pressing delete or by contextual menu > Delete Devices and Tracks

Reason crashes.

Also crashes with same steps Windows 11 Home 21H2, AMD Ryzen 9 5950X
with 12.5.97d27 LOGGING
“Assertion failure in: C:\Builds.…\Portable_Shame\ReAlizer.cpp(5332)”

Reason dev follow up:
We have examined this issue a little closer. We have received reports about this from end users as well.
It’s quite clearly indicated that there is a problem with Loopmix. Both crashes are in Loopmix and not in our code.

This bug can be even more easily triggered by:

  1. Add a loopmix vst device in Reason
  2. Open the loopmix plugin window and close it
  3. Reset the vst device

Loopmix can also crash Ableton. Tried the following:

  1. Add a track with Loopmix
  2. Save the vst presets to a file
  3. Close the Loopmix vst window
  4. Load the vst presets from the file
  5. Ableton crashes

I will close this ticket now since there is nothing we can do about this.

Please feel free to contact Audiomodern about this bug.

Hope you find the solution. I am also a Reason user, R12. I only have Playbeat but held back from buying Loopmix because Playbeat was not fully functional with Reason at the time and was crashing in some cases.
Playbeat 3.2.4 is a lot better in Reason now but there is some panning issues so I’ll start my own thread for that. No crashing now.
What version of Reason are you using? I assume Reason devs are running the latest.
If you own Playbeat and how does that run in Reason for you?

I would like to purchase Loopmix so hopefully this can be looked at soon.


Thanks for the detailed feedback,
Our upcoming 1.1.2 version fixes this issue. Please expect the update to be available by next week.

Thank you for your patience.

1 Like

Yes, I have been having the same issue with Loopmix in Ableton as well, consistently crashes after a while. All other plugins from Audiomodern work without a hitch though…

Ableton 11.3.3 both Loopmix and Riffer appear to cause Ableton to crash. In the case of Loopmix, also re-opens as a trial version and needs to be reinstalled. M1 Mac. Playbeat, Riffer and Chordjam no issues. I have updated to latest Loopmix version.

1 Like

Hello brianwdowling,

For Loopmix, This means that you still have the trial version installed.
You simply need to remove/trash the Loopmix_trial files from the location(s) below:

The AU plugin is at location:

The VSTs are at locations:

The AAX plugin is at:
/Library/Application Support/Avid/Audio/Plug-Ins

For Riffer, which version (VST/VT3) produces the problem? Do you perhaps have a crash log that you can share with us?

1 Like

Thanks, I uninstalled the trial version as you’ve suggested.

Loopmix is still causing crashes though, does not seem to be any specific pattern or set of actions that cause this. This does not happen using ReasonStudios, so am assuming it is probably unique to Ableton.

Sorry, it is not Riffer but Filterstep. I have the free version, every time I add to a track, Ableton crashes. Not sure if it is related to the Loopmix issue. The same rash with Filterstep does not happen in ReasonStudios.

Not sure how to attach a crash report to this thread, I used upload button but Ableton Zip file was greyed out.



Thanks for the info.

Are you using the latest 1.1.3 version of Filterstep?
You can download it here: Latest Software Updates | Audiomodern

Thanks, this seems to have fixed the Filterstep issue. Brian

I also experience crashes of Ableton 11.3.4 with Loopmix VST3.

I am on an Apple M1 runing MacOS 13.4.1 and updated Loopmix to Version 1.1.2.

Steps to reproduce :

  1. new Ableton Live set
  2. add Loopmix to the first MIDI Track
  3. save the Live Set and close Ableton Live
  4. open Ableton Live and chose File → Open Recent Set → and pick the saved Live Set
  5. Ableton Live crahes

The top of the call stack (tip of the crashing ice berg :wink:

Thread 0 Crashed:: MainThread Dispatch queue: com.apple.main-thread
0 Loopmix 0x128007dfc juce::ListBox::updateContent() + 44
1 Loopmix 0x127d54a00 AMMidiManager::loadFromXml(juce::XmlElement const*) + 1868
2 Loopmix 0x127d91458 AMManager::loadStateFromXml(juce::XmlElement*, bool) + 4952
3 Loopmix 0x127d9b148 AMProcessor::setStateInformation(void const*, int) + 72
4 Loopmix 0x127d31790 juce::JuceVST3Component::setStateInformation(void const*, int) + 284
5 Loopmix 0x127d314f8 juce::JuceVST3Component::loadVST2CompatibleState(char const*, int) + 172
6 Loopmix 0x127d29b40 juce::JuceVST3Component::setState(Steinberg::IBStream*) + 716
7 Live 0x104b9ecd0 0x1027d4000 + 37530832

The VST2 version of Loopmix though, lets Ableton “stay alive” :wink:



We have fixed an issue with the VST3 version of Loopmix causing Live 11.3.4 to crash.
If you are using this latest Live version and the VST3 version of Loopmix, please head over to our updates page and download/install the latest Loopmix version 1.1.3

Happy music making!

Great news, but unfortunately the MacOS installer got an error.

I tried it 2 times (with a second download), but I still get the same error message “installation failed” in the last step of the installer process.

What might be a hint : in the titlebar of the installer it states “Loopmix 1.0.2” - don’t know if this is the version of the installer or the content, hence a failure in the installer packaging process might be the cause, picking up an old version.

In the downlod the installer has the fileneme “Loopmix 1.1.3 (macOS).pkg” though.

I am on an Apple M1, so this might be something else to consider.

Another thing, just out of curiosity : the previous version of the VST3 crashed in Abelton, but not in Bitwig. How can this happen?

I thought VST3 is a standard and hence all DAWs / Hosts should behave the same way (standards & consistent behavior - I hear you laughing ;-). Or had this something to do with the UI of the Loopmix plugin that ran in its own thread and “technical environment”.

In other words : was the problem outside the VST3 technology stack that happens in the host and some other “non VST3 thing” had a sideeffect that let Ableton crash, while Bitiwig was not affected?

Would be very nice, if you could unleash some of the technical causes - thanks in advance.


Hi soundya,

This has nothing to do with the installer version, although we have to update this to avoid confusion.

Seems like a general Ventura thing. Here (Cannot install any .pkg files - Apple Community) they recommend to move the installer from the Downloads folder to the Desktop.

Let me know if this works for you.

this workaround via desktop worked - but I had to permit the installer access to files on the desktop (during the installation process).

I know this “ask for access permission” from other installers, but they use it to delete the *.pkg file after the installation has finished, which was not the case with the Loopmix installer.

So this might point to the cause of the problem - dispite beeing a “bug alike” on Apples side. But I think there will something on your installers side too, as I got no problems with other *.pkg installers.

Anyways, it worked, which is great - thanks for your help.

Have a nice day & cheers

1 Like